Browser Compatibility

Most problems in Blackboard arise from incompatibility issues with your browser or software on your computer.

Recommended Browser

We strongly recommend Blackboard students use the latest version of Mozilla Firefox for Windows or Mac because it is the most compatible with our current Blackboard systems.

Browser Compatibility Check

The first step to see if your computer is set up for Blackboard is to check your browser compatibility.

Image showing compatibility check success messages

The Blackboard browser check will check the following configurations:

  • Browser Check: Checks to see if the browser you are using is validated for use with Blackboard. At this time, we only support browsers that are Compatible or Certified.
  • JavaScript Check: Almost every part of the Learning System relies on JavaScript for the ability to generate interactive web pages. You must have JavaScript enabled.
  • Cookies Check: Makes sure your browser is configured to allow cookies, small bits of data Blackboard stores on your computer.
  • Pop-up Blocker: The Learning System sometimes uses small browser windows to deliver requested content.
  • Port 80 Check: Port 80 is your standard Internet port and its how information enters your computer from Blackboard.
  • Java Check: Checks to make sure Java is installed on your system.
  • PDF Check: Verifies that you can open Adobe Acrobat files.

Pay attention to any warnings that indicate potential compatibility issues. You will see a check mark for every test that you pass. If you see a failure message, you may need to update your settings.

Operating System and Browser Compatibility

The following operating systems and browsers are tested for UALR’s current version of Blackboard. It is strongly recommended that you use the current release of Firefox for Windows or Mac OS X.

Web Browsers XP
(32-bit)
Vista
(32-bit)
Vista
(64-bit)
Windows 7
(32-bit)
Windows 7
(64-bit)
IE 8 Compatible Compatible Compatible Compatible Compatible
IE 9 Unsupported Certified Compatible Certified Compatible
Firefox
(Final Release Channel)
Compatible Certified Compatible Certified Compatible
Firefox 3.6 Compatible Compatible Compatible Compatible Compatible
Chrome
(Stable Channel)
Compatible Compatible Compatible Certified Compatible
Web Browsers 10.5
(Leopard)
10.6
(Snow Leopard)
10.7
(Lion)
Safari 4.x Compatible Compatible Unsupported
Safari 5.0 Compatible Certified Unsupported
Safari 5.1 Unsupported Compatible Compatible
Firefox (Final Release Channel) Compatible Certified Compatible
Firefox 3.6 Compatible Compatible Compatible
Chrome (Stable Channel) Compatible Certified Compatible
Key
Certified Certified configurations are fully tested and supported
Compatible Compatible configurations are partially tested but should function properly
Unsupported Unsupported configurations are either impossible or not tested.

Additional Browser Compatibility Notes

  • Blackboard strives to make all its products as accessible as possible. JAWS for Windows 11 and 12 were used during accessibility testing.
  • Blackboard Learn requires the latest version of Sun JRE 6. The JRE can be downloaded from http://java.sun.com/javase/downloads/index.jsp. JRE 7 is not supported.
  • The following technologies are not supported:
    • Internet Explorer 6 and Internet Explorer 7
    • Firefox 1.x, 2.0, 3.0, and 3.5
    • Safari 2.0, 3.x (or any version on Windows)
    • Mac OSX 10.4 “Tiger”
    • Java 5
  • Internet Explorer 8 and Internet Explorer 9 are tested in Standards Mode. Some known issues can be resolved by using Compatibility Mode (emulates IE7 behavior).
  • Both Google Chrome and Mozilla Firefox have moved to a rapid release cycle. At the time of testing, Chrome 16.0 and Firefox 9.0 were the latest available versions. Since then, new stable versions may have been released and widely adopted. Blackboard is supporting all newer stable versions of Chrome and Firefox.

Source: Behind the Blackboard Knowledge Base