Using Internet Explorer? Then read this

Our latest version of WordPress no longer supports Internet Explorer version 7 and below, meaning that while the browser appears to work, the full slate of WordPress features won’t.

Site managers who are using a lower version of that browser will want to upgrade to the latest version of Internet Explorer, or, as we recommend, a different browser such as Safari, Firefox, or Chrome.

If you are still on the old WordPress template, you must always use Firefox for it to work.

Posted in: Announcements

Comments are closed.